import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# https://regex101.com/r/fP1oQ6/2\n"
+ "(?(DEFINE)#\n"
+ "(?<W>\\s*)\n"
+ "(?<V>\\d+(?:\\.\\d+)?(?&W))\n"
+ "(?<S>[-+]?)\n"
+ "(?<O>(?&W)[-+*\\/](?&W))\n"
+ "(?<E>(?&S)(?:(?&V)|\\((?&W)(?&E)(?&W)\\))(?:(?&O)(?&E))?)#\n"
+ ")#\n"
+ "((?&E))";
final String string = "(8 - 1 + 3) * 6 - ((3 + 7) * 2)";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}