re = /(close_app|open_app)/
str = 'https://app.twinpush.com/api/v2/apps/f1ad9f0348ea3149/devices/147680904a9a9f66/open_app
'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result