re = /\/\*[^*]*\*+([^\/][^*]*\*+)*\//
str = '/**
* Test function \\-\'-/
*
* @param nothing
*/
function test() {
/* Function */
return; /* End of
the function */
}
/* This works ! */'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end