$re = '/\/\*[^*]*\*+([^\/][^*]*\*+)*\//';
$str = '/**
* Test function \\-\'-/
*
* @param nothing
*/
function test() {
/* Function */
return; /* End of
the function */
}
/* This works ! */';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);