import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^=((?<component>[^ ]*(SUPERVISOR))|(?<severity>[^ ]*(INFO))).*\\s+(?<time>[^ =]*)\\s+[=]*\\n(?<message>(?s)^(.*?)(?:(?:\\r*\\n){2}))";
final String string = "=SUPERVISOR REPORT==== 5-Jul-2017::14:10:58 ===\n"
+ " Supervisor: {<0.15737.0>,amqp_channel_sup_sup}\n"
+ " Context: shutdown_errorhttps://regex101.com/r/QpRINz/1/tests\n"
+ " Reason: shutdown\n"
+ " Offender: [{nb_children,1},\n"
+ " {name,channel_sup},\n"
+ " {mfargs,\n"
+ " {amqp_channel_sup,start_link,\n"
+ " [direct,<0.15736.0>,\n"
+ " <<\"<rabbit@rabbitmq-default-Control.3.15736.0>\">>]}},\n"
+ " {restart_type,temporary},\n"
+ " {shutdown,brutal_kill},\n"
+ " {child_type,supervisor}]\n\n"
+ "=INFO REPORT==== 24-Jul-2017::08:44:03 ===\n"
+ "Starting RabbitMQ 3.4.4 on Erlang 17.5.6\n"
+ "Copyright (C) 2007-2014 GoPivotal, Inc.\n"
+ "Licensed under the MPL. See http://www.rabbitmq.com/\n\n"
+ "=INFO REPORT==== 24-Jul-2017::08:44:03 ===\n"
+ "node : rabbit@rabbitmq-default-Control\n"
+ "home dir : /var/lib/rabbitmq\n"
+ "config file(s) : /etc/rabbitmq/rabbitmq.config\n"
+ "cookie hash : jlzhQcHOuBZ03iv7GFo/pQ==\n"
+ "log : /var/log/rabbitmq/rabbit@rabbitmq-default-Control.log\n"
+ "sasl log : /var/log/rabbitmq/rabbit@rabbitmq-default-Control-sasl.log\n"
+ "database dir : /var/lib/rabbitmq/mnesia/rabbit@rabbitmq-default-Control\n\n"
+ "=INFO REPORT==== 24-Jul-2017::08:44:05 ===\n"
+ "Limiting to approx 65436 file handles (58890 sockets)\n\n"
+ "=INFO REPORT==== 24-Jul-2017::08:44:05 ===\n"
+ "Memory limit set to 58079MB of 145198MB total.\n\n"
+ "=INFO REPORT==== 24-Jul-2017::08:44:05 ===\n"
+ "Disk free limit set to 50MB\n\n"
+ "=INFO REPORT==== 24-Jul-2017::08:44:05 ===\n"
+ "msg_store_transient: using rabbit_msg_store_ets_index to provide index\n\n"
+ "=INFO REPORT==== 24-Jul-2017::08:44:05 ===\n"
+ "msg_store_persistent: using rabbit_msg_store_ets_index to provide index\n\n"
+ "=WARNING REPORT==== 24-Jul-2017::08:44:05 ===\n"
+ "msg_store_persistent: rebuilding indices from scratch\n\n"
+ "=INFO REPORT==== 24-Jul-2017::08:44:05 ===\n"
+ "started TCP Listener on 10.60.2.90:5672\n\n"
+ "=INFO REPORT==== 24-Jul-2017::08:44:05 ===\n"
+ "accepting AMQP connection <0.4941.0> (10.60.2.82:47767 -> 10.60.2.90:5672)\n\n"
+ "=INFO REPORT==== 24-Jul-2017::08:44:05 ===\n"
+ "accepting AMQP connection <0.4949.0> (10.60.2.82:47768 -> 10.60.2.90:5672)\n\n"
+ "=INFO REPORT==== 24-Jul-2017::08:44:05 ===\n"
+ "accepting AMQP connection <0.4952.0> (10.60.2.82:47769 -> 10.60.2.90:5672)\n\n"
+ "=SUPERVISOR REPORT==== 5-Jul-2017::23:11:58 ===\n"
+ " Supervisor: {<0.23464.1>,amqp_channel_sup_sup}\n"
+ " Context: shutdown_error\n"
+ " Reason: shutdown\n"
+ " Offender: [{nb_children,1},\n"
+ " {name,channel_sup},\n"
+ " {mfargs,\n"
+ " {amqp_channel_sup,start_link,\n"
+ " [direct,<0.23463.1>,\n"
+ " <<\"<rabbit@rabbitmq-default-Control.3.23463.1>\">>]}},\n"
+ " {restart_type,temporary},\n"
+ " {shutdown,brutal_kill},\n"
+ " {child_type,supervisor}]\n\n"
+ "=SUPERVISOR REPORT==== 6-Jul-2017::06:20:58 ===\n"
+ " Supervisor: {<0.22665.2>,amqp_channel_sup_sup}\n"
+ " Context: shutdown_error\n"
+ " Reason: shutdown\n"
+ " Offender: [{nb_children,1},\n"
+ " {name,channel_sup},\n"
+ " {mfargs,\n"
+ " {amqp_channel_sup,start_link,\n"
+ " [direct,<0.22664.2>,\n"
+ " <<\"<rabbit@rabbitmq-default-Control.3.22664.2>\">>]}},\n"
+ " {restart_type,temporary},\n"
+ " {shutdown,brutal_kill},\n"
+ " {child_type,supervisor}]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}