using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^=((?<component>[^ ]*(SUPERVISOR))|(?<severity>[^ ]*(INFO))).*\s+(?<time>[^ =]*)\s+[=]*\n(?<message>(?s)^(.*?)(?:(?:\r*\n){2}))";
string input = @"=SUPERVISOR REPORT==== 5-Jul-2017::14:10:58 ===
Supervisor: {<0.15737.0>,amqp_channel_sup_sup}
Context: shutdown_errorhttps://regex101.com/r/QpRINz/1/tests
Reason: shutdown
Offender: [{nb_children,1},
{name,channel_sup},
{mfargs,
{amqp_channel_sup,start_link,
[direct,<0.15736.0>,
<<""<rabbit@rabbitmq-default-Control.3.15736.0>"">>]}},
{restart_type,temporary},
{shutdown,brutal_kill},
{child_type,supervisor}]
=INFO REPORT==== 24-Jul-2017::08:44:03 ===
Starting RabbitMQ 3.4.4 on Erlang 17.5.6
Copyright (C) 2007-2014 GoPivotal, Inc.
Licensed under the MPL. See http://www.rabbitmq.com/
=INFO REPORT==== 24-Jul-2017::08:44:03 ===
node : rabbit@rabbitmq-default-Control
home dir : /var/lib/rabbitmq
config file(s) : /etc/rabbitmq/rabbitmq.config
cookie hash : jlzhQcHOuBZ03iv7GFo/pQ==
log : /var/log/rabbitmq/rabbit@rabbitmq-default-Control.log
sasl log : /var/log/rabbitmq/rabbit@rabbitmq-default-Control-sasl.log
database dir : /var/lib/rabbitmq/mnesia/rabbit@rabbitmq-default-Control
=INFO REPORT==== 24-Jul-2017::08:44:05 ===
Limiting to approx 65436 file handles (58890 sockets)
=INFO REPORT==== 24-Jul-2017::08:44:05 ===
Memory limit set to 58079MB of 145198MB total.
=INFO REPORT==== 24-Jul-2017::08:44:05 ===
Disk free limit set to 50MB
=INFO REPORT==== 24-Jul-2017::08:44:05 ===
msg_store_transient: using rabbit_msg_store_ets_index to provide index
=INFO REPORT==== 24-Jul-2017::08:44:05 ===
msg_store_persistent: using rabbit_msg_store_ets_index to provide index
=WARNING REPORT==== 24-Jul-2017::08:44:05 ===
msg_store_persistent: rebuilding indices from scratch
=INFO REPORT==== 24-Jul-2017::08:44:05 ===
started TCP Listener on 10.60.2.90:5672
=INFO REPORT==== 24-Jul-2017::08:44:05 ===
accepting AMQP connection <0.4941.0> (10.60.2.82:47767 -> 10.60.2.90:5672)
=INFO REPORT==== 24-Jul-2017::08:44:05 ===
accepting AMQP connection <0.4949.0> (10.60.2.82:47768 -> 10.60.2.90:5672)
=INFO REPORT==== 24-Jul-2017::08:44:05 ===
accepting AMQP connection <0.4952.0> (10.60.2.82:47769 -> 10.60.2.90:5672)
=SUPERVISOR REPORT==== 5-Jul-2017::23:11:58 ===
Supervisor: {<0.23464.1>,amqp_channel_sup_sup}
Context: shutdown_error
Reason: shutdown
Offender: [{nb_children,1},
{name,channel_sup},
{mfargs,
{amqp_channel_sup,start_link,
[direct,<0.23463.1>,
<<""<rabbit@rabbitmq-default-Control.3.23463.1>"">>]}},
{restart_type,temporary},
{shutdown,brutal_kill},
{child_type,supervisor}]
=SUPERVISOR REPORT==== 6-Jul-2017::06:20:58 ===
Supervisor: {<0.22665.2>,amqp_channel_sup_sup}
Context: shutdown_error
Reason: shutdown
Offender: [{nb_children,1},
{name,channel_sup},
{mfargs,
{amqp_channel_sup,start_link,
[direct,<0.22664.2>,
<<""<rabbit@rabbitmq-default-Control.3.22664.2>"">>]}},
{restart_type,temporary},
{shutdown,brutal_kill},
{child_type,supervisor}]
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}