import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!.*\\/)(.*)-(([^-]+)-([0-9]+))-([^.]+)(\\.chi\\.zst)";
final String string = "http://localhost/\n"
+ "http://localhost/packages/a/\n"
+ "http://localhost/packages/b/\n"
+ "http://localhost/packages/c/\n"
+ "http://localhost/packages/core/\n"
+ "http://localhost/packages/d/\n"
+ "http://localhost/packages/e/\n"
+ "http://localhost/packages/f/\n"
+ "http://localhost/packages/g/\n"
+ "http://localhost/packages/h/\n"
+ "http://localhost/packages/i/\n"
+ "http://localhost/packages/j/\n"
+ "http://localhost/packages/k/\n"
+ "http://localhost/packages/l/\n"
+ "http://localhost/packages/m/\n"
+ "http://localhost/packages/meta/\n"
+ "http://localhost/packages/n/\n"
+ "http://localhost/packages/o/\n"
+ "http://localhost/packages/p/\n"
+ "http://localhost/packages/q/\n"
+ "http://localhost/packages/r/\n"
+ "http://localhost/packages/s/\n"
+ "http://localhost/packages/t/\n"
+ "http://localhost/packages/u/\n"
+ "http://localhost/packages/v/\n"
+ "http://localhost/packages/w/\n"
+ "http://localhost/packages/x/\n"
+ "http://localhost/packages/y/\n"
+ "http://localhost/packages/z/\n"
+ "http://localhost/packages/a/atkmm-2.28.2-2-x86_64.chi.zst\n"
+ "http://localhost/packages/a/atom-1.61.0beta0-2-x86_64.chi.zst\n"
+ "http://localhost/packages/a/atril-1.26.0-1-x86_64.chi.zst\n"
+ "http://localhost/packages/a/attica-5.94.0-1-x86_64.chi.zst\n"
+ "http://localhost/packages/a/attr-2.5.1-2-x86_64.chi.zst\n"
+ "http://localhost/packages/a/aubio-0.4.9-13-x86_64.chi.zst\n"
+ "http://localhost/packages/a/aubio-0.4.9-7-x86_64.chi.zst\n"
+ "http://localhost/packages/a/audacious-4.0.5-1-x86_64.chi.zst\n"
+ "http://localhost/packages/a/audacious-plugins-4.0.5-1-x86_64.chi.zst\n"
+ "http://localhost/packages/a/audacity-1:2.4.1-7-x86_64.chi.zst\n"
+ "http://localhost/packages/a/audiofile-0.3.6-6-x86_64.chi.zst\n"
+ "http://localhost/packages/a/audit-3.0.8-1-x86_64.chi.zst\n"
+ "http://localhost/packages/a/augeas-1.12.0-2-x86_64.chi.zst\n"
+ "http://localhost/packages/a/auracle-git-r366.8739929-4-x86_64.chi.zst\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}