#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?!.*\/)(.*)-(([^-]+)-([0-9]+))-([^.]+)(\.chi\.zst)"
Local $sString = "http://localhost/" & @CRLF & _
"http://localhost/packages/a/" & @CRLF & _
"http://localhost/packages/b/" & @CRLF & _
"http://localhost/packages/c/" & @CRLF & _
"http://localhost/packages/core/" & @CRLF & _
"http://localhost/packages/d/" & @CRLF & _
"http://localhost/packages/e/" & @CRLF & _
"http://localhost/packages/f/" & @CRLF & _
"http://localhost/packages/g/" & @CRLF & _
"http://localhost/packages/h/" & @CRLF & _
"http://localhost/packages/i/" & @CRLF & _
"http://localhost/packages/j/" & @CRLF & _
"http://localhost/packages/k/" & @CRLF & _
"http://localhost/packages/l/" & @CRLF & _
"http://localhost/packages/m/" & @CRLF & _
"http://localhost/packages/meta/" & @CRLF & _
"http://localhost/packages/n/" & @CRLF & _
"http://localhost/packages/o/" & @CRLF & _
"http://localhost/packages/p/" & @CRLF & _
"http://localhost/packages/q/" & @CRLF & _
"http://localhost/packages/r/" & @CRLF & _
"http://localhost/packages/s/" & @CRLF & _
"http://localhost/packages/t/" & @CRLF & _
"http://localhost/packages/u/" & @CRLF & _
"http://localhost/packages/v/" & @CRLF & _
"http://localhost/packages/w/" & @CRLF & _
"http://localhost/packages/x/" & @CRLF & _
"http://localhost/packages/y/" & @CRLF & _
"http://localhost/packages/z/" & @CRLF & _
"http://localhost/packages/a/atkmm-2.28.2-2-x86_64.chi.zst" & @CRLF & _
"http://localhost/packages/a/atom-1.61.0beta0-2-x86_64.chi.zst" & @CRLF & _
"http://localhost/packages/a/atril-1.26.0-1-x86_64.chi.zst" & @CRLF & _
"http://localhost/packages/a/attica-5.94.0-1-x86_64.chi.zst" & @CRLF & _
"http://localhost/packages/a/attr-2.5.1-2-x86_64.chi.zst" & @CRLF & _
"http://localhost/packages/a/aubio-0.4.9-13-x86_64.chi.zst" & @CRLF & _
"http://localhost/packages/a/aubio-0.4.9-7-x86_64.chi.zst" & @CRLF & _
"http://localhost/packages/a/audacious-4.0.5-1-x86_64.chi.zst" & @CRLF & _
"http://localhost/packages/a/audacious-plugins-4.0.5-1-x86_64.chi.zst" & @CRLF & _
"http://localhost/packages/a/audacity-1:2.4.1-7-x86_64.chi.zst" & @CRLF & _
"http://localhost/packages/a/audiofile-0.3.6-6-x86_64.chi.zst" & @CRLF & _
"http://localhost/packages/a/audit-3.0.8-1-x86_64.chi.zst" & @CRLF & _
"http://localhost/packages/a/augeas-1.12.0-2-x86_64.chi.zst" & @CRLF & _
"http://localhost/packages/a/auracle-git-r366.8739929-4-x86_64.chi.zst" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")