import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([-+]?\\d*\\.?\\d*)?([-+]\\d*\\.?\\d*)[ijJ]";
final String string = "1+j unmatch\n"
+ "1+0j\n"
+ "-1+0j\n"
+ "1.1+0j\n"
+ "-1.1+0j\n"
+ "1.1+1j\n"
+ "1.1+1.1j\n"
+ "-1.1-1.1j\n"
+ "-1.1+1.1j\n"
+ "1.1-1.1j\n"
+ "-1.1j\n"
+ "5j unmatch\n"
+ "-5j\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}