package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([-+]?\d*\.?\d*)?([-+]\d*\.?\d*)[ijJ]`)
var str = `1+j unmatch
1+0j
-1+0j
1.1+0j
-1.1+0j
1.1+1j
1.1+1.1j
-1.1-1.1j
-1.1+1.1j
1.1-1.1j
-1.1j
5j unmatch
-5j
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}