# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^jdbc:oracle:thin:((?P<username>[a-zA-Z0-9]{1,})([\/](?P<password>[a-zA-Z0-9]{1,})){0,1}){0,1}@(?P<ezdb_name>((\/\/){0,1}(?P<hostname>[a-zA-Z0-9\.\-]{1,})(\:(?P<port>\d+)){0,1})(\/(?P<service_name>[a-zA-Z\.\-0-9]{1,}(\:(?P<server_type>[a-zA-Z]{1,})){0,1}){0,1}(\/(?P<instance_name>[a-zA-Z0-9]{1,})){0,1}){0,1})$"
test_str = ("jdbc:oracle:thin:@//hostname.example.ru:1521/database.example.ru\n"
"jdbc:oracle:thin:@sales-server\n"
"jdbc:oracle:thin:@sales-server:3456\n"
"jdbc:oracle:thin:@sales-server/sales\n"
"jdbc:oracle:thin:@sales-server:80/sales\n"
"jdbc:oracle:thin:@sales-server/sales:dedicated/inst1\n"
"jdbc:oracle:thin:@sales-server//inst1\n"
"jdbc:oracle:thin:@sales-server:1521/sales.us.acme.com\n"
"jdbc:oracle:thin:@//sales-server/sales.us.acme.com\n"
"jdbc:oracle:thin:@//sales-server.us.acme.com/sales.us.oracle.com\n"
"jdbc:oracle:thin:wat@//sales-server.us.acme.com/sales.us.oracle.com\n"
"jdbc:oracle:thin:wat/wat@//sales-server.us.acme.com/sales.us.oracle.com\n"
"jdbc:oracle:thin:wat/wat@//sales-server.us.acme.com/sales.us.oracle.com:dedicated/instance\n"
"jdbc:oracle:thin:wat/wat@//sales-server.us.acme.com//instance\n"
"jdbc:oracle:thin:@hostname:1521:DATABASE\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.