import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^jdbc:oracle:thin:((?P<username>[a-zA-Z0-9]{1,})([\\/](?P<password>[a-zA-Z0-9]{1,})){0,1}){0,1}@(?P<ezdb_name>((\\/\\/){0,1}(?P<hostname>[a-zA-Z0-9\\.\\-]{1,})(\\:(?P<port>\\d+)){0,1})(\\/(?P<service_name>[a-zA-Z\\.\\-0-9]{1,}(\\:(?P<server_type>[a-zA-Z]{1,})){0,1}){0,1}(\\/(?P<instance_name>[a-zA-Z0-9]{1,})){0,1}){0,1})$";
final String string = "jdbc:oracle:thin:@//hostname.example.ru:1521/database.example.ru\n"
+ "jdbc:oracle:thin:@sales-server\n"
+ "jdbc:oracle:thin:@sales-server:3456\n"
+ "jdbc:oracle:thin:@sales-server/sales\n"
+ "jdbc:oracle:thin:@sales-server:80/sales\n"
+ "jdbc:oracle:thin:@sales-server/sales:dedicated/inst1\n"
+ "jdbc:oracle:thin:@sales-server//inst1\n"
+ "jdbc:oracle:thin:@sales-server:1521/sales.us.acme.com\n"
+ "jdbc:oracle:thin:@//sales-server/sales.us.acme.com\n"
+ "jdbc:oracle:thin:@//sales-server.us.acme.com/sales.us.oracle.com\n"
+ "jdbc:oracle:thin:wat@//sales-server.us.acme.com/sales.us.oracle.com\n"
+ "jdbc:oracle:thin:wat/wat@//sales-server.us.acme.com/sales.us.oracle.com\n"
+ "jdbc:oracle:thin:wat/wat@//sales-server.us.acme.com/sales.us.oracle.com:dedicated/instance\n"
+ "jdbc:oracle:thin:wat/wat@//sales-server.us.acme.com//instance\n"
+ "jdbc:oracle:thin:@hostname:1521:DATABASE\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}