$re = '/(?:http?:\/\/|https?:\/\/)?(?:www\.)?dribbble\.com\/(?:\/*)([\w\-\.]*)/m';
$str = 'https://www.dribbble.com/epiccoders?id=107523146&authType=name&authToken=A2nj&trk=nmp_pymk_name
http://dribbble.com/name/';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;