const regex = /(?:http?:\/\/|https?:\/\/)?(?:www\.)?dribbble\.com\/(?:\/*)([\w\-\.]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:http?:\\\/\\\/|https?:\\\/\\\/)?(?:www\\.)?dribbble\\.com\\\/(?:\\\/*)([\\w\\-\\.]*)', 'gm')
const str = `https://www.dribbble.com/epiccoders?id=107523146&authType=name&authToken=A2nj&trk=nmp_pymk_name
http://dribbble.com/name/`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);