use strict;
my $str = 'пн: 10:00-19:00, обед: 14:00-15:00 вт: 10:00-19:00, обед: 14:00-15:00 ср: 10:00-19:00, обед: 14:00-15:00 чт: 10:00-19:00, обед: 14:00-15:00 пт: 10:00-19:00, обед: 14:00-15:00 сб: 10:00-14:00, обед: 14:00-15:00
пн-вск 20-22';
my $regex = qr/((?![\s\-обед])[а-я]{2,3}|[а-я]{2,3}-[а-я]{2,3})[:\s]+([\d:\-]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}