using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?![\s\-обед])[а-я]{2,3}|[а-я]{2,3}-[а-я]{2,3})[:\s]+([\d:\-]+)";
string input = @"пн: 10:00-19:00, обед: 14:00-15:00 вт: 10:00-19:00, обед: 14:00-15:00 ср: 10:00-19:00, обед: 14:00-15:00 чт: 10:00-19:00, обед: 14:00-15:00 пт: 10:00-19:00, обед: 14:00-15:00 сб: 10:00-14:00, обед: 14:00-15:00
пн-вск 20-22";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}