$re = '/[0-9]{5}/';
$str = 'zip code: 98105';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);