package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9]{5}`)
var str = `zip code: 98105`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}