import Foundation
let pattern = #""_id" : "CollectiveAgreement:(?!8|12|19|20|88|109)(\d).*?""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
{
"_index" : "documents-prod",
"_type" : "_doc",
"_id" : "CollectiveAgreement:19-Document:17-DocumentSection:269757-DocumentModule:320620",
"_score" : 0.0,
"_source" : {
"id" : "CollectiveAgreement:19-Document:17-DocumentSection:269757-DocumentModule:320620",
"type" : "CollectiveAgreement",
"title" : "Bemanning LO-förbunden (adm. ansvarigt förb. Musikerförbundet)",
"text" : "Ordinarie arbetstid uppgår för heltidsanställd till 40 tim per helgfri vecka i genomsnitt per 4-veckorsperiod. Efter lokal överenskommelse kan längre begränsningsperioder tillämpas.",
"path" : "/agreements/19/documents/17#mod-4498813045",
"memberOrganizationFamilyIds" : [ ],
"collectiveAgreementMerkuriusIds" : [
"a0ce80f7-ff07-de11-b4e1-02bf9e69ca65"
]
}
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)