import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"_id\" : \"CollectiveAgreement:(?!8|12|19|20|88|109)(\\d).*?\"";
final String string = "{\n"
+ " \"_index\" : \"documents-prod\",\n"
+ " \"_type\" : \"_doc\",\n"
+ " \"_id\" : \"CollectiveAgreement:19-Document:17-DocumentSection:269757-DocumentModule:320620\",\n"
+ " \"_score\" : 0.0,\n"
+ " \"_source\" : {\n"
+ " \"id\" : \"CollectiveAgreement:19-Document:17-DocumentSection:269757-DocumentModule:320620\",\n"
+ " \"type\" : \"CollectiveAgreement\",\n"
+ " \"title\" : \"Bemanning LO-förbunden (adm. ansvarigt förb. Musikerförbundet)\",\n"
+ " \"text\" : \"Ordinarie arbetstid uppgår för heltidsanställd till 40 tim per helgfri vecka i genomsnitt per 4-veckorsperiod. Efter lokal överenskommelse kan längre begränsningsperioder tillämpas.\",\n"
+ " \"path\" : \"/agreements/19/documents/17#mod-4498813045\",\n"
+ " \"memberOrganizationFamilyIds\" : [ ],\n"
+ " \"collectiveAgreementMerkuriusIds\" : [\n"
+ " \"a0ce80f7-ff07-de11-b4e1-02bf9e69ca65\"\n"
+ " ]\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}