package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(\d+)-(\d+)\s+(.*)`)
var str = `3-01 Wait for It.mp4
3-02 We're Not from Here.mp4
3-03 Third Wheel.mp4
3-04 Little Boys.mp4
3-05 How I Met Everyone Else.mp4
3-06 I'm Not That Guy.mp4
3-07 Dowisetrepla.mp4
3-08 Spoiler Alert.mp4
3-09 Slapsgiving.mp4
3-10 The Yips.mp4
3-11 The Platinum Rule.mp4
3-12 No Tomorrow.mp4
3-13 Ten Sessions.mp4
3-14 The Bracket.mp4
3-15 The Chain of Screaming.mp4
3-16 Sandcastles in the Sand.mp4
3-17 The Goat.mp4
3-18 Rebound Bro.mp4`
var substitution = "How I Met Your Mother S$1E$2 $3"
fmt.Println(re.ReplaceAllString(str, substitution))
}