$re = '`(?P<mount>rockcut/aws)/(?P<meta>data)?/(?P<env>(dev|test|stage|prod))?/(?P<app>\w+)?/?(?P<team>\w+)?`m';
$str = 'rockcut/aws/data/dev/someapp/s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);