package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<mount>rockcut/aws)/(?P<meta>data)?/(?P<env>(dev|test|stage|prod))?/(?P<app>\w+)?/?(?P<team>\w+)?`)
var str = `rockcut/aws/data/dev/someapp/s`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}