use strict;
my $str = 'Test-Straße 1
Chaussée de Tirlemont 373
Mühlenstraße 23
Straße des 17. Juni 135
4th Street 12ab
3rd Avenue 1435
Hamburger Str. 11-19
K4 12
Test-Str. 12ab
Test-Str. 12a-d
Test Str. 51 16
Test-Str. 17/18
Test Str. QA/3/31
Test Str. 51 / XX / 31';
my $regex = qr/^(?<street>(?!\d+ )[\p{L}\d'\u2018-\u2019]+\.?(?:[ -][\p{L}\d'\u2018-\u2019]+\.?)*(?<! \d+)),? (?<houseNumber>[1-9\p{L}][\d\p{L}]*(?:(?: | ?[\-/+,] ?)[\d\p{L}]+)*?)$/ump;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}