use strict;
my $str = 'Nos dois sistemas.
Em 22 de maio de 2018 10:23, Sistema Delta <sistemaerp@deltasi.com.br>
escreveu:
> ##- Não escreva abaixo desta linha -##
>
> *Comentário adicionado por FERNANDO TEIXEIRA BARROS em 22/05/2018 10:23*
> *Usuário:* FERNANDO TEIXEIRA BARROS* Data:* 22/05/2018 10:23:25
>
> *COMENTÁRIO:*
> Bom dia Mayla,
> Apenas sistema Montafarma?
> ------------------------------
>
> *ID Reporte: * #1468
> *Situação: * *ABERTO*
> *Módulo:* Produção
> *Tela:* ordem de pedido
> *Nome: * mayla.capana - MAYLA CAPANA
> *Emissão: * 22/05/2018 12:00:00
> *Fechamento: * -
> *Responsável: * DELTA SI
> *Prioridade: * Urgente
> *Tipo: * Ajuda
>
> *MENSAGEM: *
> Bom dia,
>
> Por favor liberar o meu acesso, Izac e Priscila, para a tela de Produção -
> Ordem de Pedido. (igual a tela que a Iza tem acesso).
>
> Aguardo retorno.
>
> Até,
>
>';
my $regex = qr/(?:[0-2])?[0-9]:[0-5][0-9](?::[0-5][0-9])?(?:(?:\\s)?[AP]M)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}