#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[0-2])?[0-9]:[0-5][0-9](?::[0-5][0-9])?(?:(?:\\s)?[AP]M)?"
Local $sString = "Nos dois sistemas." & @CRLF & _
"" & @CRLF & _
"Em 22 de maio de 2018 10:23, Sistema Delta <sistemaerp@deltasi.com.br>" & @CRLF & _
"escreveu:" & @CRLF & _
"" & @CRLF & _
"> ##- Não escreva abaixo desta linha -##" & @CRLF & _
">" & @CRLF & _
"> *Comentário adicionado por FERNANDO TEIXEIRA BARROS em 22/05/2018 10:23*" & @CRLF & _
"> *Usuário:* FERNANDO TEIXEIRA BARROS* Data:* 22/05/2018 10:23:25" & @CRLF & _
">" & @CRLF & _
"> *COMENTÁRIO:*" & @CRLF & _
"> Bom dia Mayla," & @CRLF & _
"> Apenas sistema Montafarma?" & @CRLF & _
"> ------------------------------" & @CRLF & _
">" & @CRLF & _
"> *ID Reporte: * #1468" & @CRLF & _
"> *Situação: * *ABERTO*" & @CRLF & _
"> *Módulo:* Produção" & @CRLF & _
"> *Tela:* ordem de pedido" & @CRLF & _
"> *Nome: * mayla.capana - MAYLA CAPANA" & @CRLF & _
"> *Emissão: * 22/05/2018 12:00:00" & @CRLF & _
"> *Fechamento: * -" & @CRLF & _
"> *Responsável: * DELTA SI" & @CRLF & _
"> *Prioridade: * Urgente" & @CRLF & _
"> *Tipo: * Ajuda" & @CRLF & _
">" & @CRLF & _
"> *MENSAGEM: *" & @CRLF & _
"> Bom dia," & @CRLF & _
">" & @CRLF & _
"> Por favor liberar o meu acesso, Izac e Priscila, para a tela de Produção -" & @CRLF & _
"> Ordem de Pedido. (igual a tela que a Iza tem acesso)." & @CRLF & _
">" & @CRLF & _
"> Aguardo retorno." & @CRLF & _
">" & @CRLF & _
"> Até," & @CRLF & _
">" & @CRLF & _
">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")