const regex = /\)\s+references\s+(?:\[.+?\](?:\.\[.+?\])*)\s+\((\[(.+?)\](,\[(.+?)\])*)\)\s+on\s+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\)\\s+references\\s+(?:\\[.+?\\](?:\\.\\[.+?\\])*)\\s+\\((\\[(.+?)\\](,\\[(.+?)\\])*)\\)\\s+on\\s+', 'gm')
const str = `Alter table [xxx].[sRISRESPPol] add Constraint [FK_cUcZnak_sRISRESPPol] foreign key([IdUcZnak],[IfUcZnak],[huhu]) references [dbo].[dbo].[cUcZnak] ([xx],[Id],[FirstId]) on update no action on delete no action
var regexFK = /\\]\\s+?foreign\\s+?key\\((\\[(.+?)\\](,\\[(.+?)\\])*)\\)\\s+?references\\s+?\\[/g;
var regexPrimaryTable = /\\)\\s+references\\s+(?:\\[.+?\\]\\.)*\\[(.+?)\\]\\s+\\(/g;
foreignTable ^Alter\\s+?table\\s+?(?:\\[.+?]+?\\]\\.)*\\[(.+?)\\]\\s+?add\\s+?Constraint\\s+?\\[
PK \\)\\s+references\\s+(?:\\[.+?\\](?:\\.\\[.+?\\])*)\\s+\\((\\[(.+?)\\](,\\[(.+?)\\])*)\\)\\s+on\\s+
M1 112-173 ) references [dbo].[dbo].[cUcZnak] ([xx],[Id],[FirstId]) on
G1 148-167 [xx],[Id],[FirstId]
G2 149-151 xx
G3 157-167 ,[FirstId]
G4 159-166 FirstId`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}