package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\)\s+references\s+(?:\[.+?\](?:\.\[.+?\])*)\s+\((\[(.+?)\](,\[(.+?)\])*)\)\s+on\s+`)
var str = `Alter table [xxx].[sRISRESPPol] add Constraint [FK_cUcZnak_sRISRESPPol] foreign key([IdUcZnak],[IfUcZnak],[huhu]) references [dbo].[dbo].[cUcZnak] ([xx],[Id],[FirstId]) on update no action on delete no action
var regexFK = /\]\s+?foreign\s+?key\((\[(.+?)\](,\[(.+?)\])*)\)\s+?references\s+?\[/g;
var regexPrimaryTable = /\)\s+references\s+(?:\[.+?\]\.)*\[(.+?)\]\s+\(/g;
foreignTable ^Alter\s+?table\s+?(?:\[.+?]+?\]\.)*\[(.+?)\]\s+?add\s+?Constraint\s+?\[
PK \)\s+references\s+(?:\[.+?\](?:\.\[.+?\])*)\s+\((\[(.+?)\](,\[(.+?)\])*)\)\s+on\s+
M1 112-173 ) references [dbo].[dbo].[cUcZnak] ([xx],[Id],[FirstId]) on
G1 148-167 [xx],[Id],[FirstId]
G2 149-151 xx
G3 157-167 ,[FirstId]
G4 159-166 FirstId`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}