import Foundation
let pattern = #"(A|D)?R?(B|C|E|F)?(G[12]?)?L?S?(M[12]?)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"ARFLSM2Z"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}