$re = '/(A|D)?R?(B|C|E|F)?(G[12]?)?L?S?(M[12]?)?/';
$str = 'ARFLSM2Z';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);