# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"cat\s+.*\.xml(.*)\[Expert@Arcus-mgmt1\]#\s?"
test_str = ("cat namedQueries1.xml\n"
"<?xml version=\"1.0\" encoding=\"ISO-8859-1\" ?>\n\n"
"<NamedQueriesConfiguration xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xsi:noNamespaceSchemaLocation=\"NamedCloudQueries.xsd\">\n\n"
" <NamedQuery>\n"
" <Name>SC2</Name>\n"
" <RequestedInformation>AssignedIP</RequestedInformation>\n"
" <Constraint>\n"
" <FieldName>VdcName</FieldName>\n"
" <Operator>Equals</Operator>\n"
" <Value>SC2</Value> \n"
" </Constraint> \n"
" </NamedQuery>\n"
" \n"
" <NamedQuery>\n"
" <Name>SC1</Name>\n"
" <RequestedInformation>AssignedIP</RequestedInformation>\n"
" <Constraint>\n"
" <FieldName>VdcName</FieldName>\n"
" <Operator>Equals</Operator>\n"
" <Value>SC1</Value> \n"
" </Constraint> \n"
" </NamedQuery>\n"
" \n"
"</NamedQueriesConfiguration>[Expert@Arcus-mgmt1]#")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.