import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "cat\\s+.*\\.xml(.*)\\[Expert@Arcus-mgmt1\\]#\\s?";
final String string = "cat namedQueries1.xml\n"
+ "<?xml version=\"1.0\" encoding=\"ISO-8859-1\" ?>\n\n"
+ "<NamedQueriesConfiguration xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xsi:noNamespaceSchemaLocation=\"NamedCloudQueries.xsd\">\n\n"
+ " <NamedQuery>\n"
+ " <Name>SC2</Name>\n"
+ " <RequestedInformation>AssignedIP</RequestedInformation>\n"
+ " <Constraint>\n"
+ " <FieldName>VdcName</FieldName>\n"
+ " <Operator>Equals</Operator>\n"
+ " <Value>SC2</Value> \n"
+ " </Constraint> \n"
+ " </NamedQuery>\n"
+ " \n"
+ " <NamedQuery>\n"
+ " <Name>SC1</Name>\n"
+ " <RequestedInformation>AssignedIP</RequestedInformation>\n"
+ " <Constraint>\n"
+ " <FieldName>VdcName</FieldName>\n"
+ " <Operator>Equals</Operator>\n"
+ " <Value>SC1</Value> \n"
+ " </Constraint> \n"
+ " </NamedQuery>\n"
+ " \n"
+ "</NamedQueriesConfiguration>[Expert@Arcus-mgmt1]#";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}