$re = '/^PT(?>(?\'hours\'\d+)(?>H))?(?>(?\'minutes\'\d+)(?>M))?(?>(?\'seconds\'\d+)(?>S))?/m';
$str = 'PT02M31S
PT01H02M31S
PT22M02S
PT02H22S';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);