const regex = /^PT(?>(?'hours'\d+)(?>H))?(?>(?'minutes'\d+)(?>M))?(?>(?'seconds'\d+)(?>S))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^PT(?>(?\'hours\'\\d+)(?>H))?(?>(?\'minutes\'\\d+)(?>M))?(?>(?\'seconds\'\\d+)(?>S))?', 'gm')
const str = `PT02M31S
PT01H02M31S
PT22M02S
PT02H22S`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}