# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r'^.*(201710)[0-9]{2}.*$'
test_str = ("ing_smac_process_data_full_20171025_csv\n"
"ing_smaci_process_data_delta_20171026_csv\n"
"ing_smaci_process_data_delta_20171027_csv\n"
"ing_smaci_process_data_delta_20171028_csv\n"
"ing_smaci_process_data_delta_20171029_csv\n"
"ing_smaci_process_data_delta_20171030_csv\n"
"ing_smaci_process_data_delta_20171031_csv\n"
"ing_smaci_process_data_delta_20171101_csv\n"
"ing_smaci_process_data_delta_20171102_csv")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur'' to prefix the regex and u"" to prefix the test string and substitution.