#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*(201710)[0-9]{2}.*$"
Local $sString = "ing_smac_process_data_full_20171025_csv" & @CRLF & _
"ing_smaci_process_data_delta_20171026_csv" & @CRLF & _
"ing_smaci_process_data_delta_20171027_csv" & @CRLF & _
"ing_smaci_process_data_delta_20171028_csv" & @CRLF & _
"ing_smaci_process_data_delta_20171029_csv" & @CRLF & _
"ing_smaci_process_data_delta_20171030_csv" & @CRLF & _
"ing_smaci_process_data_delta_20171031_csv" & @CRLF & _
"ing_smaci_process_data_delta_20171101_csv" & @CRLF & _
"ing_smaci_process_data_delta_20171102_csv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")