package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)((?:\/\*|\/\/|--).*)`)
var str = `/*blah blah*/ab 123
abcksklsdnvnkd // dnvsv EOD
data --ccomments EOD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}