using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)((?:\/\*|\/\/|--).*)";
string input = @"/*blah blah*/ab 123
abcksklsdnvnkd // dnvsv EOD
data --ccomments EOD";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}