re = /(?<style>[^\\]*)\\\\(?<color>[^\\]*)\\\\(?<size>[^$]*)/ix
str = '1205114074\\\\D009\\\\40'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end