package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?<style>[^\\]*)\\\\(?<color>[^\\]*)\\\\(?<size>[^$]*)`)
var str = `1205114074\\D009\\40`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}