re = /\A[\r\n\s\]\[\\\^$@~#%.&|?;,*`+()\-_<>{}\/]*/
str = ',,+?;,///() @anbvdc d+/,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end