package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\A[\r\n\s\]\[\\\^$@~#%.&|?;,*`+()\-_<>{}\/]*`)
var str = `,,+?;,///() @anbvdc d+/,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}