const regex = /data-reactid="([0-9a-zA-Z\.\$\:]*)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('data-reactid="([0-9a-zA-Z\\.\\$\\:]*)"', 'g')
const str = `<div class="Select is-searchable" data-reactid=".0.2.0.0.\$1.0.0.0.1.0.0"><input type="hidden" value="" data-reactid=".0.2.0.0.\$1.0.0.0.1.0.0.0"><div class="Select-control" data-reactid=".0.2.0.0.\$1.0.0.0.1.0.0.1"><div class="Select-placeholder" data-reactid=".0.2.0.0.\$1.0.0.0.1.0.0.1.0:\$placeholder">Select...</div><div class="Select-input" style="display:inline-block;" data-reactid=".0.2.0.0.\$1.0.0.0.1.0.0.1.1"><input value="" tabindex="0" style="width:5px;" data-reactid=".0.2.0.0.\$1.0.0.0.1.0.0.1.1.0"><div style="position: absolute; visibility: hidden; height: 0px; width: 0px; overflow: scroll; white-space: nowrap; font-size: 16.2000007629395px; font-family: montserrat, sans-serif;" data-reactid=".0.2.0.0.\$1.0.0.0.1.0.0.1.1.1"></div></div><span class="Select-arrow" data-reactid=".0.2.0.0.\$1.0.0.0.1.0.0.1.2"></span></div></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}