#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "data-reactid="([0-9a-zA-Z\.\$\:]*)""
Local $sString = "<div class="Select is-searchable" data-reactid=".0.2.0.0.$1.0.0.0.1.0.0"><input type="hidden" value="" data-reactid=".0.2.0.0.$1.0.0.0.1.0.0.0"><div class="Select-control" data-reactid=".0.2.0.0.$1.0.0.0.1.0.0.1"><div class="Select-placeholder" data-reactid=".0.2.0.0.$1.0.0.0.1.0.0.1.0:$placeholder">Select...</div><div class="Select-input" style="display:inline-block;" data-reactid=".0.2.0.0.$1.0.0.0.1.0.0.1.1"><input value="" tabindex="0" style="width:5px;" data-reactid=".0.2.0.0.$1.0.0.0.1.0.0.1.1.0"><div style="position: absolute; visibility: hidden; height: 0px; width: 0px; overflow: scroll; white-space: nowrap; font-size: 16.2000007629395px; font-family: montserrat, sans-serif;" data-reactid=".0.2.0.0.$1.0.0.0.1.0.0.1.1.1"></div></div><span class="Select-arrow" data-reactid=".0.2.0.0.$1.0.0.0.1.0.0.1.2"></span></div></div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")