re = /(\d*[.]?\d*) fps/
str = 'Stream #0:0(und): Video: h264 (Main) (avc1 / 0x31637661), yuv420p(tv, bt709), 1256x1028, 12567 kb/s, SAR 1:1 DAR 314:257, 32.2 fps, 60 tbr, 6k tbn, 50 tbc (default)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end