const regex = /(\d*[.]?\d*) fps/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d*[.]?\\d*) fps', '')
const str = `Stream #0:0(und): Video: h264 (Main) (avc1 / 0x31637661), yuv420p(tv, bt709), 1256x1028, 12567 kb/s, SAR 1:1 DAR 314:257, 32.2 fps, 60 tbr, 6k tbn, 50 tbc (default)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}