re = /\(([^\(\)]*\w*)\)/
str = '( Alfa [ Charlie Delta ( Bravo [ Echo ( Foxtrot Golf ) ] ) ] )'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end