package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(([^\(\)]*\w*)\)`)
var str = `( Alfa [ Charlie Delta ( Bravo [ Echo ( Foxtrot Golf ) ] ) ] )`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}