$re = '`(?s)\.GetModification(?:String|Number|Bool|Object|Array)\(\s*["\']([\w\-]+)[\'"]\s*,\s*(["\'][^"]*[\'"]|[+-]?(?:\d*[.])?\d+|true|false|False|True)(?:\s*,\s*(?:true|false|\d+|"[^"]*"))?\s*\)`m';
$str = ' discountName, err := fsVisitor.GetModificationString("btnColor", "VString", true)
discountName, err := fsVisitor.GetModificationString("btnColor", "sjkfhskd", true)
discountName, err := fsVisitor.GetModificationNumber("btnSize", 13, true)
discountName, err := fsVisitor.GetModificationBool("showBtn", false, true)
discountName, err := fsVisitor.GetModificationString("btnColor", "VString")
discountName, err := fsVisitor.GetModificationNumber("btnSize", 13)
discountName, err := fsVisitor.GetModificationBool("showBtn", false)
discountName, err := fsVisitor.GetModificationString("btnColor", "VString")
discountName, err := fsVisitor.GetModificationNumber("btnSize", "red, green, blue", false)
discountName, err := fsVisitor.GetModificationBool("showBtn", "(false moha)")
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);