using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\.GetModification(?:String|Number|Bool|Object|Array)\(\s*[""']([\w\-]+)['""]\s*,\s*([""'][^""]*['""]|[+-]?(?:\d*[.])?\d+|true|false|False|True)(?:\s*,\s*(?:true|false|\d+|""[^""]*""))?\s*\)";
string input = @" discountName, err := fsVisitor.GetModificationString(""btnColor"", ""VString"", true)
discountName, err := fsVisitor.GetModificationString(""btnColor"", ""sjkfhskd"", true)
discountName, err := fsVisitor.GetModificationNumber(""btnSize"", 13, true)
discountName, err := fsVisitor.GetModificationBool(""showBtn"", false, true)
discountName, err := fsVisitor.GetModificationString(""btnColor"", ""VString"")
discountName, err := fsVisitor.GetModificationNumber(""btnSize"", 13)
discountName, err := fsVisitor.GetModificationBool(""showBtn"", false)
discountName, err := fsVisitor.GetModificationString(""btnColor"", ""VString"")
discountName, err := fsVisitor.GetModificationNumber(""btnSize"", ""red, green, blue"", false)
discountName, err := fsVisitor.GetModificationBool(""showBtn"", ""(false moha)"")
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}